The best way to see if and how a solution works is to test it. The proof of the pudding is in 
the eating they say. For this I have created a small testlab. While building it I ran into a little problem. 
But it had to be solved to continue. For testing but also for live production I want to join my VCSA in a 
Windows domain. Since the hacking with WannaCry, caused by an SMB1 vulnerability, this is only allowed 
with the use of SMB2. The default installation of VCSA does not have SMB2 support in it so it fails.
I think this isn't just in my testlab so more people are bound to run into this.
This is why i wrote this post.
When I was setting up my test lab, I was trying to join my VCSA to the domain. 
First with the GUI and later on through SSH on the CLI. With the CLI it was more clear 
what the problem was.  
I had below error:



Looking through diverse postings I ran into a VMware knowledge article about enabling SMB2 on 
the VCSA. (https://kb.vmware.com/s/article/2150832)
But when I ran the command:
/opt/likewise/bin/lwregshell set_value 
'[HKEY_THIS_MACHINE\Services\lwio\Parameters\Drivers\rdr]' Smb2Enabled 1
it gave me a invalid syntax.
See below:


This means the value I am trying to set is not in the registry.
Just to be sure I ran  
/opt/likewise/bin/lwregshell list_values 
'[HKEY_THIS_MACHINE\Services\lwio\Parameters\Drivers\rdr]'
and indeed it wasn't there.



So in stead of setting it you have to add it
/opt/likewise/bin/lwregshell add_value 
'[HKEY_THIS_MACHINE\Services\lwio\Parameters\Drivers\rdr]' Smb2Enabled REG_DWORD 1
Now the value is there and set to 1



Hope this helps anyone setting up SMB2 on the VCSA

Author ITQ

More posts by ITQ
26 July 2019